Un vieux SPIP 1.8 : comment migrer

Suite au témoignage de migrations faciles d’un SPIP 1.9 directement en 3.1 (cf. Une montée de version "drastique" !), les questions fusent à nouveau, mais sur plus historique SPIP 1.8 !

Quelques éléments de réponse... du moins les premières pistes...

 
 
 
 

Identifier les risques potentiels

- le charset (encodage de la base)
- le charset (encodage dans les pages HTML : voir les squelettes)
- la version de la BDD (moteur et accès par l’extension php
- la version de PHP (entre la version SPIP de départ qui ne tournait que sur un PHP 4, et l’obligation d’un PHP 5.5 pour les nouvelles SPIP 3) il y a exclusion.... !
- des syntaxes obsolètes dans les squelettes (mais on commence toujours par la migration sans squelettes : voir ci-après)
- les plugins incompatibles (plusieurs causes... : version php, usage de syntaxe php, de champs de tables disparues, primitives SPIP non maintenues....)


Merci de nous signaler les coquilles ou erreurs qui figureraient dans cette page.


Liens visibles seulement pour les inscrits.

Article publié le 4 octobre, et actualisé en juillet 2016 .

Répondre à cet article